Jump to content


Photo

Game still has major frame rate issues


  • Please log in to reply
9 replies to this topic

#1 MacPharlan

MacPharlan

    Jagged Member

  • Members
  • PipPip
  • 14 posts

Posted 06 May 2012 - 03:10 AM

I see other threads similar but one seemed related to hardware and the other may be fixed, so I decided to create a new one in hopes that we may be able to get more eyes on it from Support.


I have had no issues with this game and performances (maxed settings) through the airport, Drassen City, the farm, roadblock, but when I hit the kingpin area with the city, it craaaaawlllls. I have to turn everything down and it still has issues, so bad that I have to hit key (e.g. space bar etc...) several times before they respond, often times it is to late as the 'moment' has passed.


I have a fairly respectible machine and have 'zero' problems on other games of very high graphics demand. Here are my specs (graphics drivers up to date)

Phenom II x4 955
Windows 7 64
8 GB Ram
Radeon 6870




Not sure if there are some magic tweaks that I can do, but anything would be nice as it is to frustrating to play like this.

#2 TheWickedGerman

TheWickedGerman

    Fresh Blood

  • Members
  • Pip
  • 2 posts

Posted 06 May 2012 - 10:01 PM

I had also framerate issues after the latest patch in San Mona/Kingpin´s House. Was not unplayable but very laggy. Frame rate in Sektor Alma Barracks have been fine again, as have been the sectors before San Mona & Kingpin´s house. (Drasssen, Cambria, and the smaller ones around those areas).

Playing on maxed settings, Phenom II x4 945, HD4870, 4gb ram, Win 7 64 bit.

Reducing settings seemed to do nothing.

#3 hijakR

hijakR

    Little Ivan

  • Members
  • PipPipPip
  • 31 posts

Posted 27 May 2012 - 06:52 PM

Yes, this is where i first get the massive slowdown, the Kingpin area, I have checked countless sites on this topic, I found the most common answer relating to the Civilian AI paths and possibly the enemy AI when alerted (although its very slow/stuttery before I alert anyone). What I did to test this was start a new game (pre 1.12 patches), choose Raven, ignore the airport, travel straight to Kingpin area and/or San Mona (to see if the slowdown was present)I found the slowdown wasn't present this early on in the game (so I didnt wait 50 ingame days, like I did before when the enemy numbers are doubled). I tested this again with the newer patches (1.13) and the problem is worse.

#4 hijakR

hijakR

    Little Ivan

  • Members
  • PipPipPip
  • 31 posts

Posted 27 May 2012 - 09:04 PM

I've just restarted the game using the 1.11 patch version. I used Raven,headed straight to Meduna (55 enemies and 12 civilians).No noticeable slowdown at all, I even snuck in a little bit closer, fired my gun at nothing, woke up about 20 enemies, and still no noticeable slowdown. at the minute it looks best to just rush in with minimal mercs and very little money to finish the game at a playable framerate, because if I use the newer patched version and take my time it will slow to a crawl (my system is above the reccomended system specs). so if anyone has this problem and knows the cause or a fix, please let me know.

#5 TSM

TSM

    Jagged Member

  • Members
  • PipPip
  • 29 posts

Posted 03 June 2012 - 01:47 PM

I have similar system to you guy's slow down was awful however I had some success with turning graphics down ect and using a program to allow GameJABiA.exe to use 4 gb's of ram made it even smoother its still not great but at least 50% faster in Grumm

4 GB enabler

#6 hijakR

hijakR

    Little Ivan

  • Members
  • PipPipPip
  • 31 posts

Posted 03 June 2012 - 07:40 PM

I have similar system to you guy's slow down was awful however I had some success with turning graphics down ect and using a program to allow GameJABiA.exe to use 4 gb's of ram made it even smoother its still not great but at least 50% faster in Grumm

4 GB enabler

this 4gb patch is showing as potentially mallicious as it creates executibles that can be accessed externally.The slowdown is a problem the devs should fix.

#7 TSM

TSM

    Jagged Member

  • Members
  • PipPip
  • 29 posts

Posted 03 June 2012 - 08:29 PM

personally I think your being a little paranoid to each his own I know many people who use this switch in other games with no issue's.

#8 Guest_SweetDreams_*

Guest_SweetDreams_*
  • Guests

Posted 02 October 2012 - 08:07 AM

any word on a fix, I'm having the same problem....It happens on all major cities in the game. This makes a very enjoyable game unbearable to play.

#9 Guest_south-side_*

Guest_south-side_*
  • Guests

Posted 15 October 2012 - 08:36 PM

I have the same framnrate problem as i reached Cambria. Game gets difficult to play even selecting your mercs or when going tactical you have to push sapce like 4-5 times until it's getting enabled.

I'm playing the 1.13 e patch version and it doesn't improve anything. it's too bad, game worked perfectly in sectors that were not that populated but in Cambria it seems to fall apart. Hospital as well as the university.

Can someone give us an answer please, because i like the game and i'm unable to proceed.

System:

AMD Phenom II X2 550
3.11 Ghz

3.25 GB RAM

NVidia Ge Force 9800 GT

#10 Sandman84

Sandman84

    Fresh Blood

  • Members
  • Pip
  • 1 posts

Posted 20 September 2013 - 06:07 AM

I've been playing the game on my laptop for a few days now, and haven't had too many problems until I got to Cambria. Now that I'm in Cambria, the game is frustrating and difficult to play because of the problems mentioned above. I'm running the latest version of the game, my laptop's specs are better than the recommended system requirements, and changing the game's video settings has no discernible effect. It's really sad for the game to be ruined this way. I am through with it until the developers fix the problem.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users